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What is a Spreadsheet? 

A spreadsheet is a way to organize data into rows and columns. This 
format allows users to calculate, analyze, and visually represent data. 
Examples of spreadsheet programs include Microsoft Excel, Google 
Sheets and Numbers (by Apple).  Microsoft Excel is the 
spreadsheet software offered by Microsoft Office. Excel allows you to 
organize data, complete calculations, and graph data.  

Navigating Microsoft Excel 

The Excel layout is like other Microsoft Office products. There is a 
horizontal menu across the top of the page - the ‘ribbon menu’-
where you can find most of the options for editing and formatting. 
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1. Title Bar Displays title of workbook and other quick access 
information. 

2. Quick Access Toolbar A customizable toolbar that contains a set 
of commands including Save, Undo, and Redo. 

3. Ribbon Menu Contains all of your commonly needed options, 
grouped by category. The ribbon is grouped into tabs and each tab is 
grouped by category within that tab. 

4. Formula Bar Enter and edit data, formulas, and functions that will 
appear in an active cell. 

5. Cell The intersection of a column (noted by a letter) and a row 
(noted by a number). Cell A1 is selected as an active cell above. 

6. Name Box Displays the location of the selected active cell. 

7. Worksheet Tabs Each workbook can contain multiple sheets. 
Here you can rename your sheet and add additional sheets. 

8. Status Bar Displays status on default options such as Average, 
Count, and Sum.  
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Formatting Data as a Table 

If you have a large amount of data, you can format your data as a table to 
make managing it easier. Begin by selecting (highlighting) your data. Then 
go to the Home ribbon and select Format as Table and choose a style. 
The only difference between the styles is the visual appearance. The 
dialogue box that appears will display the range you selected.  

If your data has headers in the columns, make sure that “My table has 
headers” is checked. 

 

 

Sort and Filter Data with Tables 

Formatting as a table also allows you to sort data by using the drop-down 
buttons in the header cells. Click on the drop-down for the column that you 
want to sort and select the best option. 

 

  

 

 

 

A header column drop-down 
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Filters can be used to narrow down the data in your worksheet, allowing 
you to view only the information you need. 

 

Your column headers will become drop down menus with additional 
options. Select the drop-down arrow for the item you want to filter. Simply 
check the items you’d like to view, and Excel will hide the rest of your data.  
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Formula Fundamentals 

Excel can calculate basic equations like addition, subtraction, multiplication, 
and division. By writing an equation in reverse, Excel will calculate it for 
you. However, Excel has a specific format and set of symbols to use. All 
formulas begin with an equal sign (=). 

 

 
 

 

You can also add cells together, instead of numbers. This adds the value of 
whatever is contained within the cell. These are called cell references. If 
the value of a cell (the number inside it) change, Excel automatically 
recalculated when you leave that cell. 

 

 

 

 

Excel uses some of the same symbols that we use when writing math 
problems, but there are some differences as well: 

                              Regular      Excel 

Addition + + Remember that Excel also follows the 
“Order of Operations.” You might remember 
this as Parentheses, Exponents, 
Multiplication, Division, Addition, then 
Subtraction. You can remember this as 
PEMDAS or Please Excuse My Dear Aunt 
Sally. 
 

Subtraction - - 
Multiplication x * 
Division ÷ / 
Equals = = 
Exponents xn ^ 

 
Example:  =8+5*(3+4) gives you a value of 43, not 91 

=2+2 4 

=a1+a2 4 
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Entering Formulas  
 
There’s another way to enter formulas into cells. Instead of typing in a cell 
address, you can just use your mouse to point and click on the cell you 
wish to include in a formula. This method is good when you need to select 
cells that are spread out all over the place.  

If you have multiple adjacent cells you would like to include in the same 
calculation you can click on the first cell and drag your mouse until all 
needed cells are included. The cell reference added to the formula will 
appear as first cell reference:last cell reference (for instance A1:A7). In 
this case the colon represents the word “through” and can be read as A1 
through A7. 

Functions: Predefined Excel Formulas 

A Function is a predefined formula that performs calculations using 
specific values in a particular order. 
 
Common functions: 
 

 SUM: Adds all of the values of the cells in the argument. 
 AVERAGE: Determines average of the values included in the 

argument. It calculates the sum of the cells and then divides that 
value by the number of cells in the argument. 

 COUNT: Counts the number of cells with numerical data in the 
argument. This function is useful for quickly counting items in a cell 
range. 

 MAX: Determines the highest cell value included in the argument. 
 MIN: Determines the lowest cell value included in the argument. 
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Additional specialized advanced functions are available through the 
Function Library section and are organized by topic.  

The values that you use with a function are called arguments. All functions 
begin with an equal sign and include the arguments in parentheses after 
the function name.  

 

Steps for creating a function: 

1. Click inside the cell where you want to see the formula’s results. 
2. Click on the Insert Function button located on the Formula Bar. 
3. When the Insert Function dialog box appears, select the function of 

your choice from the list, and then click OK. Note: To see additional 
functions, change the category to All. 

4. When the Function Arguments dialog box appears, either type in the 
range of cells you need analyzed into the Numbers box, or, better yet, 
click and drag to define the range you need. 

5.  Click OK and the calculated result will show up in the active cell. 

From: https://edu.gcfglobal.org/en/excel/functions/1/  
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Nesting: You can also put formulas inside of other formulas. This is called 
“Nesting.” For example, you could calculate the deviation in a range (the 
difference between the smallest value and the largest) by using: 

=SUM(-MIN(Range),MAX(Range)) 

 

AutoSum 

The AutoSum 
command allows you 
to easily insert 
common functions.  
 
You can find the 
AutoSum command 
in the Editing group 
on the Home Tab, or 
in the Formulas Tab 
on the Ribbon. 
 
Example:        =SUM(J2:J5) is the same as  =J2+J3+J4+J5 
 

The range J2:J5 contains all of the cells between J2 and J5, but you don’t 
have to write them out individually. 

Filling Across Columns and Rows 

Another way to copy formulas from one cell to another is to drag it or “fill” it 
across a range of cells (a row or a column). AutoFill can be used to quickly 
fill in the in a column or row.   

 

 

 

 

 

In the active cell of the spreadsheet, 
the Fill Handle is a small box at the 
right corner, as shown in the image to 
the right.  

Fill Handle 
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Select a cell and move the mouse pointer to the 
Fill Handle in the lower right corner where it will 
turn into a crosshair cursor. You can then click 
and drag the crosshair cursor to fill in information 
like numbers, months, days of the week, or even 
formulas. 

 

The Auto Fill Options button will appear in 
the lower right corner when you use the Fill 
Handle. Hover over the button and then 
click the downward arrow to show a menu 
of options to customize how information is 
filled. 

(NOTE: Auto Fill Options button/menu is 
only visible when viewed in Excel desktop 
app, not Microsoft 365 for web in the 
browser) 
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 Creating Charts for Your Data 

Charts allow you to illustrate your workbook data graphically, which 
makes it easy to visualize comparisons and trends. 

 

 

To insert a chart in Excel, select the data you wish to include and go to the 
Insert tab. Select Insert Chart and choose the type of chart you would like 
to use. 
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Customize Your Charts  

Once you’ve chosen a chart, you can 
customize it to your liking by choosing the 
chart layout and style in your ribbon. Excel 
allows you to add chart elements—such 
as titles, legends, and data labels to 
make your chart easier to read. To add a 
chart element, click the Add Chart 
Element command on the Design tab, then 
choose the desired element from the drop-
down menu. 
 
 
 
 
 

 
You can also reorganize your chart by selecting Switch Rows and 
Columns or use Quick Layout to change multiple elements at once. 
Change Chart Type also allows you to switch to a different type of chart. 

 
 

Themes 

Themes are available across multiple Office applications, allowing 
documents, spreadsheets, and presentations to all have the same “look.” 
To apply a theme, go to the Page Layout tab and choose Themes. 
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Headers and Footers 

Headers can appear at the top of every page of a 
printed worksheet. Footers can appear at the bottom of 
every page of a printed worksheet. To add a header or 
a footer, click on the Insert Tab, then on the Header & 
Footer option. Once you click on the Header & Footer 
tool, the Header & Footer Tools tab should appear. You can type anything 
you like into the header or footer, or you can use the tools on the ribbon 
such as Page Number or Date.  
 
 

Page Setup 

Page set up allows you to change way your page 
will print. You can access the Page Setup button 
from the Page Layout tab of the ribbon.  
 
You can also access them from the Print Preview 
screen. To get to Print Preview, go to File, then 
Print. 
 
Orientation – Whether your paper is portrait or 
landscape 
 
Size – The size of paper your workbook prints on 
 
Margins – Use can quickly use a preset or create 
your own custom one 
 
Scaling - —If your spreadsheet is very large but 
you need to get as much as possible on a page, 
you have the option of: 1) Adjusting the 
spreadsheet to a smaller (or larger) percentage of 
its current size or 2) Forcing the spreadsheet to 
print to a specific number of pages 

 

*Resources used: 
https://edu.gcfglobal.org/en/, 
https://support.microsoft.com/  
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Resources      

The following resources can be accessed from the library’s resource page: 
https://www.cmlibrary.org/resources 

GCF Learn Free 

Find many Microsoft Office, Google Suite, and basic-to-advanced digital literacy 
lessons for free on www.gcflearnfree.org. They have both text-based and video 
tutorials on a wide variety of topics.  

LinkedIn Learning  

Access a library of video tutorials from beginner to advanced level on a variety of 
technology topics on LinkedIn Learning (formerly Lynda.com).  LinkedIn Learning 
allows you to track your progress and download resources from tutorials.  You 
can view lessons at home or in the library using your library card.   

Northstar Digital Literacy 

This resource provides interactive online assessments and practice exercises to 
help individuals master computer and software skills such as using email, 
navigating the internet, and using Microsoft Word, Excel, and PowerPoint.  Learn 
to navigate technology in your daily life with assessments on topics such as 
Social Media, Google Documents, Supporting K-12 Distance Learning, and 
Career Search Skills. Receive certification in one or more topics by completing 
an assessment (score 85% or higher) during a virtual Library proctored session.  

1-on-1 Technology Tutoring 

Charlotte Mecklenburg Library offers 1-on-1 tutoring with a library staff member 
or volunteer. You can call your library branch to check availability or check out 
our online calendar at www.cmlibrary.org/calendar. 

 

 

 

 

 

DigiLit is a digital literacy program provided by 
Charlotte Mecklenburg Library. To find out more 
information about this program, download class 
handouts, and access additional resources, visit: 
www.cmlibrary.org/digilit           

 


